download:start

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
download:start [2021/03/02 23:09]
gawrilow [Windows 10 with the Linux Subsystem]
download:start [2021/03/17 10:28] (current)
benmuell [MacOS] add apple m1 bundle
Line 28: Line 28:
 ==== MacOS ==== ==== MacOS ====
  
-**NOTE**: There are no binaries ​for **Mac OS 11 (Big Sur) on arm** (the new processor developed by appleand the installation has not been tested. **Intel Macs** should be **fine**. ​+**NOTE**: There is experimental support ​for **Mac OS 11 (Big Sur) on arm** (the new M1 processor developed by Apple), please apply [[https://​polymake.org/​downloads/​patches/​apple_m1.patch|this patch]] for building polymake 4.3 (the latest master already includes these changes) and please report any issues. **Intel Macs** should be **fine**. ​
  
 === Binary Releases === === Binary Releases ===
Line 54: Line 54:
 There are precompiled bundles for MacOS between 10.11 and 11.1, see below. Install a bundle by dragging the app to /​Applications. See [[install:​macos/​bundles#​Installing the App Bundle|here for more information]]. There are precompiled bundles for MacOS between 10.11 and 11.1, see below. Install a bundle by dragging the app to /​Applications. See [[install:​macos/​bundles#​Installing the App Bundle|here for more information]].
    * polymake 4.3    * polymake 4.3
-     * [[http://​www.polymake.org/​downloads/​polybundle-v4.3-macos-11.1-perl-5.28.2.dmg|MacOS 11.1 bundle]] +     * //​experimental//​ [[https://​www.polymake.org/​downloads/​polybundle-v4.3-macos-11.2-applem1-perl-5.28.2-v1.dmg|MacOS 11.2 arm64 bundle]] for Apple M1 
-     * [[http://​www.polymake.org/​downloads/​polybundle-v4.3-macos-10.15-perl-5.18.4.dmg|MacOS 10.15 bundle]] +     * [[https://​www.polymake.org/​downloads/​polybundle-v4.3-macos-11.1-perl-5.28.2.dmg|MacOS 11.1 bundle]] 
-     * [[http://​www.polymake.org/​downloads/​polybundle-v4.3-macos-10.14-perl-5.18.4.dmg|MacOS 10.14.6 bundle]] +     * [[https://​www.polymake.org/​downloads/​polybundle-v4.3-macos-10.15-perl-5.18.4.dmg|MacOS 10.15 bundle]] 
-     * [[http://​www.polymake.org/​downloads/​polybundle-v4.3-macos-10.13-perl-5.18.2.dmg|MacOS 10.13 bundle]]+     * [[https://​www.polymake.org/​downloads/​polybundle-v4.3-macos-10.14-perl-5.18.4.dmg|MacOS 10.14.6 bundle]] 
 +     * [[https://​www.polymake.org/​downloads/​polybundle-v4.3-macos-10.13-perl-5.18.2.dmg|MacOS 10.13 bundle]]
    * polymake 4.2    * polymake 4.2
-     * [[http://​www.polymake.org/​downloads/​polybundle-release-4.2-macos-10.15-perl-5.18.4-v1.dmg|MacOS 10.15 bundle]] +     * [[https://​www.polymake.org/​downloads/​polybundle-release-4.2-macos-10.15-perl-5.18.4-v1.dmg|MacOS 10.15 bundle]] 
-     * [[http://​www.polymake.org/​downloads/​polybundle-release-4.2-macos-10.14-perl-5.18.4-v1.dmg|MacOS 10.14.6 bundle]]+     * [[https://​www.polymake.org/​downloads/​polybundle-release-4.2-macos-10.14-perl-5.18.4-v1.dmg|MacOS 10.14.6 bundle]]
    * polymake 4.0    * polymake 4.0
-     * [[http://​www.polymake.org/​downloads/​polybundle-release-4.0-macos-10.12-perl-5.18.2-v1.dmg|MacOS 10.12 bundle]]  +     * [[https://​www.polymake.org/​downloads/​polybundle-release-4.0-macos-10.12-perl-5.18.2-v1.dmg|MacOS 10.12 bundle]]  
-     * [[http://​www.polymake.org/​downloads/​polybundle-release-4.0-macos-10.11-perl-5.18.2-v1.dmg|MacOS 10.11 bundle]]+     * [[https://​www.polymake.org/​downloads/​polybundle-release-4.0-macos-10.11-perl-5.18.2-v1.dmg|MacOS 10.11 bundle]]
  
 You may need to manually unsandbox the bundle (as it is not officially signed by Apple). For this, run You may need to manually unsandbox the bundle (as it is not officially signed by Apple). For this, run
  • download/start.txt
  • Last modified: 2021/03/17 10:28
  • by benmuell